I trust that you have taken the necessary steps for a mksysb backup and raise a Change Request
I have changed the server name and the AIX version I am using is 5.3
1. We make a copy of the current JVM on the server
# cp -rp /usr/java14_64 /usr/java14_64bak
You have to create the backup directory first
# mkdir /usr/java14_64bak
# cd /usr/java14_64
# find . -print | cpio -pdl /usr/java14_64bak
cpio will copy soft links in the directory
2. We go to the temporary location of where the new JVM file is. I usually store it in /tnp
# cd /tmp/JVM
3. We unzip the file
# gunzip -c Java14.sdk.tar.gz | tar -xvf.
4. We extract the file
# tar -xvf Java14.sdk.tar.
5. Install the JDK/SDK base and update images. Do a preview installation first, if there are any error we will see it right away
Run "smitty install"
Select "Install and Update Software"
Select "Install Software"
Specify directory containing the images
then press "Enter"
run preview first for PREVIEW only? (install operation will NOT occur) and Preview new LICENSE agreements?
[Entry Fields]
* INPUT device / directory for software /tmp/JVM/
* SOFTWARE to install [_all_latest] +
PREVIEW only? (install operation will NOT occur) yes +
COMMIT software updates? yes +
SAVE replaced files? no +
AUTOMATICALLY install requisite software? yes +
EXTEND file systems if space needed? yes +
OVERWRITE same or newer versions? no +
VERIFY install and check file sizes? no +
Include corresponding LANGUAGE filesets? yes +
DETAILED output? no +
Process multiple volumes? yes +
ACCEPT new license agreements? yes +
Preview new LICENSE agreements? no
preview results:
installp PREVIEW: installation will not actually occur.
*******************************************************************************
+-----------------------------------------------------------------------------+
Pre-installation Verification...
+-----------------------------------------------------------------------------+
Verifying selections...done
Verifying requisites...done
Results...
SUCCESSES
---------
Filesets listed in this section passed pre-installation verification
and will be installed.
Selected Filesets
-----------------
Java14_64.ext.commapi 1.4.2.0 # Java SDK 64-bit Comm API Ext...
Java14_64.ext.javahelp 1.4.2.0 # Java SDK 64-bit JavaHelp
Java14_64.license 1.4.2.250 # Java SDK 64-bit License
Java14_64.samples 1.4.2.0 # Java SDK 64-bit Samples
Java14_64.sdk 1.4.2.380 # Java SDK 64-bit
Java14_64.source 1.4.2.380 # Java SDK 64-bit Source
<< End of Success Section >>
6. Do a full installation, and check the updated Java version
@smurf01/tmp# java -fullversion
java full version "J2RE 1.4.2 IBM AIX 5L for PowerPC (64 bit JVM) build caix64142-20080515 (SR11)"
Done!
No comments:
Post a Comment