I don't like messing with a prod server's swap value unless there is a direct request from a customer
Here's how you do it on HP-UX and AIX. I trust you have your CR raised
HP-UX
The default value for swappiness is 60. You can alter it temporarily (until you next reboot) by typing as root
echo 50 > /proc/sys/vm/swappiness
If you want to alter the swap value change permanently then you need to change the vm.swappiness parameter in the /etc/sysctl.conf file
Step 1: check what is the current value for swap
sudo cat /proc/sys/vm/swappiness
(It should give a number 60 here)
Step 2: change to a lower number
sudo sysctl -w vm.swappiness=5
Step 3: check again
sudo cat /proc/sys/vm/swappiness
(Now, it should give a number 5 here)
Step 4: append the line vm.swappiness=5 in file /etc/sysctl.conf using vi editor
AIX
Things are easier on AIX with the use of smitty. I used AIX version 5.3
1. Check the current paging and swapspace value
# lsps -a
# pstat -s
2. Run smitty and make changes on the fly
# smit pgsp-----to increase/decrease paging
3. Check paging and swapspace value again
# lsps -a
# pstat -s
4. To add paging space
# smit lvm---paging space---add
or
#smit mkps
Friday, August 11, 2017
# aix paging swap space
# hp-ux swap space
UNIX : Changing swap value on HP-UX and AIX
by
Brocade Blue
Subscribe to:
Post Comments (Atom)
There is no /proc in HP-UX.
ReplyDelete